Corrección: El .NET Framework 4.7 no está soportado en este sistema operativo

El .Net Framework es una infraestructura de programación introducida por Microsoft. Necesitarás el .Net Framework para ejecutar varias aplicaciones y servicios diferentes. La mayoría de las aplicaciones que requieren .Net Framework vienen con sus archivos de instalación también. Por lo tanto, se instalará automáticamente en tu sistema cuando instales una aplicación. Pero, podrías ver un error “El .NET Framework 4.7 no está soportado en este sistema operativo” al instalar una aplicación. Este error impedirá que instales la aplicación con éxito. Es posible que veas este error cuando intentes instalar el .Net Framework como una aplicación/servicio independiente.

La razón por la que ocurre este error es la misma que se menciona en el mensaje de error. A pesar de que el .Net Framework es compatible con Windows 10 pero no con todas las versiones de Windows 10. Por lo tanto, si aparece este mensaje, la causa más probable de este error es que estás ejecutando una versión de Windows 10 que no es compatible con el .Net Framework.

Método 1: Actualizar Windows 10

La única solución para este problema es simplemente actualizar su Windows 10. Se aconseja comprobar las actualizaciones de Windows aunque esté en la última versión de Windows 10. Dado que el problema se debe a un sistema operativo incompatible, la instalación de todas las actualizaciones disponibles de Windows 10 probablemente resolverá el problema. También puedes comprobar la versión exacta de tu Windows 10 y la versión requerida por el .Net Framework siguiendo los pasos que se indican a continuación.

  1. Mantenga pulsada la tecla de Windows y pulse R
  2. Escriba winver y presione Enter
También te puede interesar:  ¿Qué es LSM.EXE

  1. Su versión debe ser mencionada en la ventana recién abierta. El número que aparece después de la versión (en la segunda línea) es su número de versión. El número debe ser 1507 o 1709. Los primeros 2 dígitos son el año y los segundos 2 representan el mes. Así que si tienes una versión de 1709 entonces eso significa que estás ejecutando una versión lanzada en septiembre de 2017

  1. Ahora tienes que asegurarte de que tienes la versión de Windows 10 que es compatible con el .Net Framework. Haz clic en aquí y haz clic en Requisitos del sistema

Si miras en la sección Sistema Operativo Soportado , dice Windows 10 Anniversary Update y Windows 10 Creators update . Como mucha gente no está familiarizada con los números de versión asociados a las actualizaciones de Anniversary y Creators, los hemos mencionado a continuación

  • Actualización de noviembre (1511)
  • Actualización del aniversario (14393)
  • Actualización de Creadores (1703)
  • Actualización de Creadores de Otoño (1709)
  • Actualización de Creadores de Primavera (1803)

Como pueden ver, la Actualización de Aniversario tiene el número de versión 14393 y la Actualización de Creadores tiene la versión 1703. Por lo tanto, si tienes una versión inferior a la 14393 no podrás instalar el .Net Framework 4.7 en Windows 10. Ahora simplemente actualiza el Windows y asegúrate de tener la última versión de Windows 10 e inténtalo de nuevo.

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.